24.2.10

Excel: cómo contar celdas cuyo valor esta dentro de un rango de dos fechas

Imaginemos que tenemos una columna en una hoja Excel que contiene fechas.

Y queremos contar cuántas de esas fechas pertenecen a un determinado año o a un determinado mes o está dentro de un periodo de tiempo (por ejemplo, desde el 3 de Junio 2010 hasta el 18 de Julio de 2011)…

En estos casos debemos de utilizar una fórmula semejante a esta de tipo matricial:

{=SUMA(((RANGO_CELDAS)>=FECHA(AÑO_1;MES_1;DIA_1))*((RANGO_CELDAS)<=FECHA(AÑO_2;MES_2;DIA_2)))}

Donde:
  • RANGO_CELDAS: es el rango de casillas cuyos valores vamos a revisar (por ejemplo puede ser una columna al estilo B1:B100).
  • AÑO_1: es el año de la fecha inferior del rango.
  • MES_1: es el mes de la fecha inferior del rango.
  • DIA_1: es el día de la fecha inferior del rango.
  • AÑO_2: es el año de la fecha superior del rango.
  • MES_2: es el mes de la fecha superior del rango.
  • DIA_2: es el día de la fecha superior del rango.

Para poner las llaves hay que:
1.- Poner la formula sin las llaves.

=SUMA(((RANGO_CELDAS)>=FECHA(AÑO_1;MES_1;DIA_1))*((RANGO_CELDAS)<=FECHA(AÑO_2;MES_2;DIA_2)))

2.- Pulsar Shift + Control + Enter para indicar que la fórmula es matricial (las llaves las pondrá automáticamente el sistema).



Os pongo como serían algunos ejemplos:
EJEMPLO 1) Contar las operaciones (columna B contiene la fecha de la operación) realizadas en el año 2007

{=SUMA(((B1:B65536)>=FECHA(2007;1;1))*((B2:B65536)<=FECHA(2007;12;31)))}

EJEMPLO 2) Contar las operaciones (columna B contiene la fecha de la operación) realizadas en el mes de Marzo de 2008

{=SUMA(((B1:B65536)>=FECHA(2008;3;1))*((B2:B65536)<=FECHA(2008;3;31)))}

EJEMPLO 3) Contar las operaciones (columna B contiene la fecha de la operación) realizadas entre el 3 de Junio de 2010 y el 18 de Julio de 2011

{=SUMA(((B1:B65536)>=FECHA(2010;6;3))*((B2:B65536)<=FECHA(2011;7;18)))}

Funciones útiles en Excel

AHORA(): devuelve la fecha y hora en este mismo instante.

Ejemplo:

A3 = AHORA()

Devolvería el siguiente contenido a la celda A3

A3 = 23/02/2010 18:04



CONCATENA(valor1;valo2;…): devuelve la unión de las cadenas y casillas.

Ejemplo:

A3 = CONCATENA(“Precio cerezas: ”;A4)

Devolvería el siguiente contenido a la celda A3 (suponiendo que la casillaa A4 contuviese el valor 4)

A3 = Precio cerezas: 4

Excel: cómo hacer referencia a una casilla que está en otra hoja distinta a la actual

Para hacer que una casilla contenga lo mismo que otra casilla en otra página de un archivo Excel hay que poner lo siguiente:

HOJAN!CODIGO_CASILLA

Donde:
HOJAN es el nombre de la hoja (por ejemplo, Hoja1)
CODIGO_CASILLA es el código que identifica a la casilla a la que hace referencia en la otra página (por ejemplo, A7)Por ejemplo.

Supongamos que tenemos un fichero Excel donde:

• en la Hoja 1, tenemos los precios de los productos y las cantidades que se van a comprar para, una fiesta,

• y en la hoja 2, tenemos la lista de productos a comprar y sus precios solamente.

Se poría repetir la información, pero ya que hemos rellenado la hoja1 totalmente como se ve en la siguiente figura:


No tiene sentido volver a rellenar todos estos campos para hacer la Hoja2.

Así en la hoja2 hemos escrito lo siguiente:

Casilla de la hoja2 A3 = Hoja1!A2
Casilla de la hoja2 A4 = Hoja1!A3
Casilla de la hoja2 A5 = Hoja1!A4
Casilla de la hoja2 A6 = Hoja1!A5

Casilla de la hoja2 B3 = Hoja1!B2
Casilla de la hoja2 B4 = Hoja1!B3
Casilla de la hoja2 B5 = Hoja1!B4
Casilla de la hoja2 B6 = Hoja1!B5

Con lo que tendríamos toda la información pasada sin tener que esribirlo todo de nuevo.


TRUCO: También se puede hacer navegando con el ratón en vez de escribir Hoja1!AX
Para ello basta poner el “=” y después ir a la hoja correspondiente y cliquear en la casilla que corresponda.

1.2.10

8 aspectos que apestan del iPad

http://i.gizmodo.com/5458382/8-things-that-suck-about-the-ipad

9 alternativas al Apple iPad

Programando el lanzamisiles USB para dominar el mundo

Evolucion de las aplicaciones de desarrollo de Microsoft

Hay que tener dos claves para acceder al almacenamiento de Azure

http://geeks.ms/blogs/jalarcon/archive/2010/01/28/191-por-qu-233-tenemos-dos-claves-para-acceder-al-almacenamiento-de-azure.aspx


La leere mas tarde tranquilamente.

Videos Visual Studio 2010 and ASP.NET 4.0

http://geeks.ms/blogs/lfranco/archive/2010/02/01/resumen-de-videos-de-vs2010-y-asp-net-4-0.aspx

Interesant articles about WPF and Silverlight - Enlaces interesantes WPF y Silverlight

http://geeks.ms/blogs/oalvarez/archive/2010/01/31/enlaces-interesantes-wpf-silverlight-31-01-2010.aspx