24.2.10

Excel: cómo contar celdas cuyo valor esta dentro de un rango de dos fechas

Imaginemos que tenemos una columna en una hoja Excel que contiene fechas.

Y queremos contar cuántas de esas fechas pertenecen a un determinado año o a un determinado mes o está dentro de un periodo de tiempo (por ejemplo, desde el 3 de Junio 2010 hasta el 18 de Julio de 2011)…

En estos casos debemos de utilizar una fórmula semejante a esta de tipo matricial:

{=SUMA(((RANGO_CELDAS)>=FECHA(AÑO_1;MES_1;DIA_1))*((RANGO_CELDAS)<=FECHA(AÑO_2;MES_2;DIA_2)))}

Donde:
  • RANGO_CELDAS: es el rango de casillas cuyos valores vamos a revisar (por ejemplo puede ser una columna al estilo B1:B100).
  • AÑO_1: es el año de la fecha inferior del rango.
  • MES_1: es el mes de la fecha inferior del rango.
  • DIA_1: es el día de la fecha inferior del rango.
  • AÑO_2: es el año de la fecha superior del rango.
  • MES_2: es el mes de la fecha superior del rango.
  • DIA_2: es el día de la fecha superior del rango.

Para poner las llaves hay que:
1.- Poner la formula sin las llaves.

=SUMA(((RANGO_CELDAS)>=FECHA(AÑO_1;MES_1;DIA_1))*((RANGO_CELDAS)<=FECHA(AÑO_2;MES_2;DIA_2)))

2.- Pulsar Shift + Control + Enter para indicar que la fórmula es matricial (las llaves las pondrá automáticamente el sistema).



Os pongo como serían algunos ejemplos:
EJEMPLO 1) Contar las operaciones (columna B contiene la fecha de la operación) realizadas en el año 2007

{=SUMA(((B1:B65536)>=FECHA(2007;1;1))*((B2:B65536)<=FECHA(2007;12;31)))}

EJEMPLO 2) Contar las operaciones (columna B contiene la fecha de la operación) realizadas en el mes de Marzo de 2008

{=SUMA(((B1:B65536)>=FECHA(2008;3;1))*((B2:B65536)<=FECHA(2008;3;31)))}

EJEMPLO 3) Contar las operaciones (columna B contiene la fecha de la operación) realizadas entre el 3 de Junio de 2010 y el 18 de Julio de 2011

{=SUMA(((B1:B65536)>=FECHA(2010;6;3))*((B2:B65536)<=FECHA(2011;7;18)))}

2 comments: